Categories
Audio Sources - Full Text Articles

QNAP addresses a critical flaw impacting its NAS devices

Spread the news

QNAP-logo.png?fit=436%2C228&ssl=1

Taiwanese vendor QNAP is warning customers to install QTS and QuTS firmware updates to address a critical flaw impacting its NAS devices.

QNAP released QTS and QuTS firmware updates to address a critical vulnerability, tracked as CVE-2022-27596 (CVSS v3 score: 9.8), that affects QNAP NAS devices.

A remote attacker can exploit the vulnerability to inject malicious code on QNAP NAS devices. The flaw is easy to exploit without user interaction or privileges on the vulnerable device.

The flaw impacts QTS 5.0.1 and QuTS hero h5.0.1 versions.

“A vulnerability has been reported to affect QNAP devices running QTS 5.0.1 and QuTS hero h5.0.1. If exploited, this vulnerability allows remote attackers to inject malicious code.” reads the advisory published by the Taiwanese vendor.

“We have already fixed this vulnerability in the following operating system versions:

  • QTS 5.0.1.2234 build 20221201 and later
  • QuTS hero h5.0.1.2248 build 20221215 and later”

Below is the step-by-step procedure to update QTS or QuTS hero:

  1. Log in to QTS or QuTS hero as an administrator.
  2. Go to Control Panel > System > Firmware Update.
  3. Under Live Update, click Check for Update.
    QTS or QuTS hero downloads and installs the latest available update.

Users can also download the update from the QNAP website by going to Support > Download Center and then performing a manual update for their specific device.

The company urges customers to apply security updates as soon as possible.

Follow me on Twitter: @securityaffairs and Facebook and Mastodon

Pierluigi Paganini

(SecurityAffairs – hacking, Moshen Dragon)

The post QNAP addresses a critical flaw impacting its NAS devices appeared first on Security Affairs.


Spread the news
WP Radio
WP Radio
OFFLINE LIVE